Sun vá lỗ hổng nghiêm trọng trong Java

Sun vừa bịt hai lỗ hổng bảo mật nghiêm trọng trong Java, từng cho phép tin tặc chiếm quyền điểu khiển các hệ thống Windows, Linux và Solaris.

Trong cảnh báo bảo mật được công bố ngày 14/6, Secunia đã xếp hai lỗ hổng trên ở mức "nghiêm trọng cao" (chỉ sau mức cảnh báo cao nhất - "cực kỳ nghiêm trọng"). Những hệ thống bị mắc lỗi này có thể bị khai thác từ xa và chiếm quyền điểu khiển toàn bộ hệ thống.

Cả hai lỗ hổng đều tác động tới Java Runtime Environment (JRE), một thành phần được rất nhiều máy tính sử dụng để chạy các ứng dụng Java. Sai sót này có thể cho phép ứng dụng Java đọc và ghi file, hoặc thực thi ứng dụng trên máy tính nạn nhân. Theo cảnh báo của Secunia, tin tặc có thể khai thác lỗ hổng này thông qua một trang Web độc hại.

JRE là một phần của phiên bản Java 2 Platform Standard Edition (J2SE). Cả hai lỗ hổng đều ảnh hưởng tới J2SE 5.0 và 5.0 Update 1 dành cho Windows, Solaris và Linux. Lỗ hổng còn tác động tới cả các phiên bản J2SE 1.4.2_07, J2SE 1.4.2 của các hệ điều hành này.

Sun khuyến cáo người dùng cần cài đặt bản nâng cấp (J2SE 5.0 Update 2 và J2SE 1.4.2_08) để bảo vệ máy tính trước nguy cơ tấn công của tin tặc. Trên thực tế, J2SE 5.0 Update 2 đã được ban hành từ tháng 2/2005, còn J2SE 1.4.2_08 được ban hành cách đây không lâu. Người dùng có thể tải hai bản nâng cấp này từ website Java.com.

Thứ Năm, 16/06/2005 07:36
31 👨 54
0 Bình luận
Sắp xếp theo
z