Plugin WordPress hơn 300.000 trang sử dụng có lỗ hổng dễ bị tấn công SQL Injection

Lỗi này được tìm thấy trên plugin rất phổ biến WP Statistics, cho phép người quản trị trang lấy thông tin chi tiết liên quan tới số lượng người dùng trực tuyến trên trang, lượt visit, số người visitors và các thống kê trang.

Được phát hiện bởi nhóm Sucuri, plugin WP Statistics có lỗ hổng dễ bị tấn công SQL Injection, cho đó cho phép kẻ tấn công từ xa, chỉ với 1 tài khoản đăng ký duy nhất, đánh cắp thông tin nhạy cảm từ cơ sở dữ liệu của website và có thể chiếm quyền truy cập website.

SQL Injection là một lỗi của ứng dụng web, cho phép hacker tiêm đoạn mã SQL (Structured Query Language) vào dữ liệu đầu vào của web để xác định cấu trúc, địa điểm của cơ sở dữ liệu then chốt, cuối cùng là cho phép đánh cắp thông tin từ đó.

Lỗ hổng của SQL Injection có thể nằm trên nhiều chức năng, trong đó có wp_statistics_searchengine_query()
Lỗ hổng của SQL Injection có thể nằm trên nhiều chức năng, trong đó có wp_statistics_searchengine_query()

“Lỗ hổng này là do thiếu kiểm soát với dữ liệu mà người dùng cung cấp. Một số thuộc tính của shortcode wpstatistics đã bị bỏ qua thay vì được nhìn nhận như thông số cho các chức năng quan trọng”, các nhà nghiên cứu cho biết. “Một trong những chức năng dễ bị khai thác là truy vấn tìm kiếm wp_statistics_searchengine_query() trong tập tin includes/functions/functions.php, truy cập thông qua AJAX của WordPress nhờ vào wp_ajax_parse_media_shortcode().”

Chức năng này không kiểm tra quyền ưu tiên bổ sung, là thứ cho phép người theo dõi website thực thi đoạn shortcode và tiêm mã độc vào thuộc tính. Các nhà nghiên cứu tại Sucuri đã báo cáo lỗi này tới nhóm WP Statistics và nhóm đã vá lỗ hổng này trong bản mới nhất 12.0.8. Vậy nên nếu đang dùng phiên bản còn lỗ hổng và website của bạn cho phép người dùng đăng ký thì hãy nhanh chóng cài đặt bản mới nhất.

Thứ Ba, 04/07/2017 11:16
31 👨 190